skip to primary navigationskip to content
 

PHP update

The version of PHP will change from 5.6 to 7.0

In Debian 8 (Jessie) the version of PHP is 5.6.29.

In Debian 9 (Stretch) the version of PHP is 7.0.14.

Some PHP features that have been "deprecated" in PHP 5.6 will no longer be supported in PHP 7.0.

In particular, mysql_connect is no longer supported in PHP 7, but one can use
MySQLi or PDO_MySQL instead.

There is documentation on the changes that may be needed for PHP 7.0 in the PHP manual pages on migration and deprecated functionality removed.

Our documentation on using PHP on the MWS is here.